[its-hackers] sys; atsign dragon

Ken Harrenstien iceklh at gmail.com
Thu Nov 17 03:17:04 CET 2016


On Wed, Nov 16, 2016 at 4:15 PM, Eric Swenson <eric at swenson.org> wrote:

> Hi Ken,
>
> I had forgotten whether you were following the https://github.com/PDP-10/
> its effort to bootstrap ITS from sources.
>

No, I hadn't heard of it before now.


> It currently works for me using SIMH but not using KLH10.  However, Lars
> says it works for him using KLH10.  I’m kind of at a loss at this point as
> to why.  In any case, I do have a running ITS system using KLH10 (at
> es-its.swenson.org), so I know that KLH10 works, in general.  However,
> I’m having issues with disk images built using the klh10 branch of the
> above-mentioned Git repo.
>
> NETIME dies with a .value, under SIMH, presumably because there is no
> network (IMP) support.  Or if that support exists, I don’t know how to
> configure it.  I can’t get far enough with the build on KLH10 to know
> whether it would work there.  I suspect it would, since NETIME works
> perfectly find on ES-ITS.
>
> SIMH appears to require :PDSET to be run on each bootload. I don’t know
> why. KLH10 seems perfectly able to deliver the time to ITS.
>

KLH10 knows about the hardware time clocks and remembers the offset in
a host-system disk file.


>
> Since you’ve written, perhaps you can clarify something for me.  If we use
> the klh10 branch of https://github.com/PDP-10/its to create a disk image,
> and in so doing are writing ITS and NSALV to the disk image, and then I
> boot KLH10 with “load @.its-647-es-u” (my ES-ITS image), is the version of
> ITS in the FE file system of the disk image used at all?  Are we just
> loading ITS in memory from the host file @.its-647-es-u, rather than from
> the disk?
>

You're loading ITS into memory from the host filesystem, not from the
emulated
ITS filesystem.

Note there are timing races in the original DSKDMP (or am I thinking about
NSALV?) that will cause it to fail, since the code expects the hardware disk
to take a long time but the virtual disk responds instantly and wipes out
the
code that is still being executed.



>  (This, is as opposed to loading @.ddt-u and dskdump.216bin into KLH10,
> and then loading the @.its (or whatever it is called) from the disk’s FE
> file system).  The reason I asked is that when I built a disk image using
> the above repo (klh10) branch, which writes an ITS in the FE file system,
> but rather than booting with dskdump, I boot with “load @.its-647-es-u” and
> “go”, I still exhibit corruption when attempt to rebuild midas and then use
> that built midas to assemble anything.
>

We all exhibit corruption of one kind or another, but I think you're
referring
to something about the MIDAS binary, right?  What sort of corruption?

It is entirely possible that the MIDAS binary as distributed includes some
patches that were never reflected in the MIDAS source.  Also, some programs
needed to be explicitly run and dumped (or patched and dumped) right after
being built.  PEEK is a good example of something that tried to do this
automatically based on the ITS version.

In the ITS distribution notes I tried to record all of the patches and hacks
that were needed to bring things up, but it wouldn't surprise me if I missed
a few or if there were some patches that always existed that nobody was
ever interested in cleaning up.  As you noticed, there are various bits of
software that simply remained in binary form for so long that the sources
were lost without being noticed.

I do hope you're keeping notes about everything you're running into :-)

--Ken


>  The thing I find weird about this is that I don’t think I’m using the ITS
> from the disk, but a pre-built ITS that I know works perfectly fine (since
> it is the same ITS that I use to run es-its.swenson.org).
>
> Any help would be appreciated. — Eric
>
> On Nov 16, 2016, at 16:02, Ken Harrenstien <iceklh at gmail.com> wrote:
>
> Hmm - don't remember previous msgs... build on what platform?  It was
> working for me, but my code is a bit newer.
>
> On Nov 16, 2016 11:59 AM, "Eric Swenson" <eric at swenson.org> wrote:
>
>> Looks like I’m going to be stuck and the daemon effort. CHANNA; RAKASH
>> NETIME dies on run (with a .val 0) — probably because it can’t access the
>> network.
>>
>> CHANNA; RAKASH PFTHMG is unhappy because there is no DRAGON; DRAGON
>> HOARD.  But I suspect even if I include on in sources.tape, DRAGON will be
>> unhappy because of the clock’s not being set.  It needs to read/write
>> accounting data to DRAGON; DRAGON HOARD.  It appears to start up and go
>> into a wait state — that is probably fine, and perhaps if I set the time
>> before it wakes up again, everything will be good.
>>
>> But:
>>
>>  1) we really need SIMH to return the current time to ITS.  KLH10 does
>> this fine — but as reported earlier, I cannot get KLH10 to work with your
>> build.
>>
>> 2) we need IMP support. KLH10 has it. Does SIMH?  How do we
>> enable/configure it in SIMH?
>>
>> 3) I wasn’t able to run the KLH10 build the last time I tried, and the
>> klh10 branch hasn’t been updated since the last time I tried. I’m inclined
>> to think that I can’t make progress until we have time and network
>> support.  So I was thinking I’d switch to KLH10 — however, as I reported
>> earlier, the build doesn’t succeed on that branch.
>>
>> Suggestions? — Eric
>>
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://its.victor.se/mailman/private/its-hackers_its.victor.se/attachments/20161116/53c3e04e/attachment-0001.html>


More information about the its-hackers mailing list